Перейти к содержанию

Важное изменение в правилах форума!!! Обязательно к ознакомлению: http://carmasters.org/topic/20603-поправка-к-правилам-форума-№1-всем-ознакомиться-в-обязательном-порядке/

Авторизация  
Alexkor555

EDC15C7 Hyundai Tucson 2.0 2005 - Ремонт

Рекомендуемые сообщения

Прислал человек EDC15C7 Hyundai Tucson 2.0 2005, BOSCH HW=0281011690, 39104-27260 9AJ2TI01 - не работает и с ним второй с разборки, для клонирования  BOSCH HW=0281011694, SW=1037372113.

Второй проверил на столе - все ок, переписал все с первого - отправил, человек получил, поставил - завелась, едет - все ОК.

На Первом  - нет 5 Вольт на памяти и на проце и на ....  Микросхема Bosch DC-DC в корпусе HSOP36 умерла, заказал в Китае - пришла, поставил - все напруги выдает, но не генерит один из кварцев, надпись на нем  447NDK43. Не могу нигде найти на какую он частоту? Прошу помощи разпознать .... А может дело не в Кварце, может я не туда....?

Изменено пользователем Alexkor555

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Фотки блока в студию, что то я не могу припомнить где в едс15 стоит второй кварц, один стоит у проца c167го, а второй?...........

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

оба стоят у проца - один выше 453NDK44, второй 447NDK43 сбоку - между памятью AM29F400BT и процемedc15c7_.jpg.2b24272f115c3b628595b69e399d1482.jpg

 

оба стоят у проца - один выше 453NDK44, второй 447NDK43 сбоку - между памятью AM29F400BT и процем. Эта фотка с Инета - там надписи на кварцах другие, но я не разберу

нашел вот такую фотку, тут четко видна надпись на кварце, но Гугл не находит.. ((

ALFA-EDC15C7.JPG

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Дак у вас на проце кварц молчит?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
3 часа назад, Alexkor555 сказал:

Прислал человек EDC15C7 Hyundai Tucson 2.0 2005, BOSCH HW=0281011690, 39104-27260 9AJ2TI01 - не работает и с ним второй с разборки, для клонирования  BOSCH HW=0281011694, SW=1037372113.

Второй проверил на столе - все ок, переписал все с первого - отправил, человек получил, поставил - завелась, едет - все ОК.

На Первом  - нет 5 Вольт на памяти и на проце и на ....  Микросхема Bosch DC-DC в корпусе HSOP36 умерла, заказал в Китае - пришла, поставил - все напруги выдает, но не генерит один из кварцев, надпись на нем  447NDK43. Не могу нигде найти на какую он частоту? Прошу помощи разпознать .... А может дело не в Кварце, может я не туда....?

если мне память не изменяет на 16 мегагерц

442NDK - 4 MHz
443NFK - 6MHz
444NDK - 8 MHz
445NDK - 10 MHz
446NDK - 12 MHz
447NDK - 16 MHz

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Сними флешку и в прогер проверь живая она или нет

может по 5 вольтам все померло

тогда в мусорку

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
2 часа назад, Евжениус сказал:

Сними флешку и в прогер проверь живая она или нет

может по 5 вольтам все померло

тогда в мусорку

по 5V в первом посту написано. На самом кварце есть 5 Вольт, но нет синусоиды((( А как флэшка может влиять на синхру? Или я чего-то не понимаю? Помогите люди добрые плизз.

4 часа назад, gluharenko сказал:

если мне память не изменяет на 16 мегагерц

442NDK - 4 MHz
443NFK - 6MHz
444NDK - 8 MHz
445NDK - 10 MHz
446NDK - 12 MHz
447NDK - 16 MHz

Спасибо большое!!! Это уже дело!

2 часа назад, gluharenko сказал:

потому нету генерации на кварце?

Имеете ввиду из-за флэшки?

4 часа назад, gluharenko сказал:

если мне память не изменяет на 16 мегагерц

442NDK - 4 MHz
443NFK - 6MHz
444NDK - 8 MHz
445NDK - 10 MHz
446NDK - 12 MHz
447NDK - 16 MHz

на фото выше это 816KS052T он же 447NDK43 т.е. это 16МГц - спасибо !!! Или проц сдох? INFINEON B59388 - как проверить его без выпайки? 

По даташиту у него Maximum Clock Rate 25MHz. Т.е. заказываю, покупаю на 16_МГц., способ проверки Clock Rate процессора INFINEON B59388 может кто подскажет. 

нашел что INFINEON B59388 – BDO 31358  - это Infineon C167. Это так же, как Siemens C166 (7).

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
4 часа назад, Alexkor555 сказал:

по 5V в первом посту написано. На самом кварце есть 5 Вольт, но нет синусоиды((( А как флэшка может влиять на синхру? Или я чего-то не понимаю? Помогите люди добрые плизз.

Спасибо большое!!! Это уже дело!

Имеете ввиду из-за флэшки?

на фото выше это 816KS052T он же 447NDK43 т.е. это 16МГц - спасибо !!! Или проц сдох? INFINEON B59388 - как проверить его без выпайки? 

По даташиту у него Maximum Clock Rate 25MHz. Т.е. заказываю, покупаю на 16_МГц., способ проверки Clock Rate процессора INFINEON B59388 может кто подскажет. 

нашел что INFINEON B59388 – BDO 31358  - это Infineon C167. Это так же, как Siemens C166 (7).

Нашел даташит Infineon C167 -  The frequency range of the PWM signals covers 4 Hz to 16.5 MHz (referred to a CPU clock of 33 MHz) .

Померял осликом рабочий кварц 453NDK44 - работает на частоте 10.25МГц. И этот кварц с процессором INFINEON B59388 не связан - прозвонил трассировку. Он связан с NEC UPD790008GF.

заказал кварц на 16МГц - жду.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Кварц поменял, но как и ожидалось, хотя очень не хотелось признаться себе - кварц оказался не при делах, а вина лежит на проце, больше не вижу причин. Нужно менять проц. На кварц подумал по причине того что выпаивал феном память и мог его перегреть ... попробую еще кондеры в обвязке кварца выпаять - померять - поменять... Может будет от кого подсказка ....??? Мжно ли на проце по замеру на выводах XTAL-1 XTAL-2  определиться исправен у него осциллятор или нет ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
4 часа назад, Alexkor555 сказал:

Кварц поменял, но как и ожидалось, хотя очень не хотелось признаться себе - кварц оказался не при делах, а вина лежит на проце, больше не вижу причин. Нужно менять проц. На кварц подумал по причине того что выпаивал феном память и мог его перегреть ..

маловероятно, это нужно постараться... а вот проц мог и проговориться

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

отпаял конденсаторы на выводах кварца и сам кварц - на выводах XTAL-1 XTAL-2  никаких колебаний не обнаружено (((

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 09.02.2019 в 20:21, Alexkor555 сказал:

Кварц поменял, но как и ожидалось, хотя очень не хотелось признаться себе - кварц оказался не при делах, а вина лежит на проце, больше не вижу причин. Нужно менять проц. На кварц подумал по причине того что выпаивал феном память и мог его перегреть ... попробую еще кондеры в обвязке кварца выпаять - померять - поменять... Может будет от кого подсказка ....??? Мжно ли на проце по замеру на выводах XTAL-1 XTAL-2  определиться исправен у него осциллятор или нет ?

да .OSC_OUT должен иметь противоположность OSC_IN

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
2 часа назад, casus сказал:

да .OSC_OUT должен иметь противоположность OSC_IN

Вижу только постоянку на одном +5В на втором +4.5В относительно земли.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

к питанию или земле жестко притянут должен быть только выход. внутри ИС стоит инвертор с отрицательной обратной связью и триггером шмитта

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

в обвязке кварц-проц вообще ни к земле ни к питанию +5В ничего не притянуто. Сам проц выдает эти +5В... (точнее на одной ноге кварца 4.2В на другой 3.6В) будем менять МК...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 12.02.2019 в 22:58, Alexkor555 сказал:

в обвязке кварц-проц вообще ни к земле ни к питанию +5В ничего не притянуто. Сам проц выдает эти +5В... (точнее на одной ноге кварца 4.2В на другой 3.6В) будем менять МК...

Пришел с Китая процессор C167CR-LM (а стоит B58388) вроде одинаковые они. Запаял - кварц загенерил, а вот связи с блоком пока не получил....Эбу не отвечает...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
5 часов назад, Alexkor555 сказал:

Пришел с Китая процессор C167CR-LM (а стоит B58388) вроде одинаковые они. Запаял - кварц загенерил, а вот связи с блоком пока не получил....Эбу не отвечает...

Похоже что нужно прошивку менять под этот процессор или прошивать сам проц ??? Кто знает , помогите словом....

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

В проце C167CR нет внутренней прошивки.

Если этот проц аналог твоего старая прошивка должна работать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
10 часов назад, Alexkor555 сказал:

Эбу не отвечает...

Проверь флешь, проверь UART, проверь все +5вольт которые приходят на проц, только питалово проверяй на сомих пинах проца т.к. возможна такая ситуация когда до пина питание доходит, а на сомом пине нет, питание сомого UART 109, 110 пины проца, сам UART 77, 78 пины проца, на нашем форуме есть прога flashit при помощи которой можно протестить эти процы https://carmasters.org/topic/1095-ремонт-и-восстановление-autocom/?page=1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
13 часов назад, os88 сказал:

В проце C167CR нет внутренней прошивки.

Если этот проц аналог твоего старая прошивка должна работать.

Олег большое спасибо - я об этом уже где-то слышал, но развеял мои сомнения.

Володя - Тебе огромное спасибо, по питанию проца все ок. А вот по UART проблема , с микросхемы B58251 SOP16 выхода UART нету. Т.е. К-линия приходит на 30402 Бош, а затем на B58251 SOP16 и потерялась.... Даташита на B58251 SOP16 ни у кого нету или может кто подскажет аналог.....

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
5 минут назад, Alexkor555 сказал:

К-линия приходит на 30402 Бош, а затем на B58251 SOP16

Не понятно, обычно 77 и 78 пины проца (UART) идут на драйвер к-линии, если с драйвером к-линии всё в порядке то на обоих пинах (77, 78) будет присутствовать логическая "1", в противном случае, если драйвер к-линии не работает, т.е. на драйвере нет одного из питаний (+5, +12в) то на приёмнике проца не будет лог. " 1", если у проца отсутствует питание на 109 и 110 пинах то на передатчике проца не будет лог. "1"..................

Как то так..................

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
50 минут назад, dyrokol сказал:

Не понятно, обычно 77 и 78 пины проца (UART) идут на драйвер к-линии, если с драйвером к-линии всё в порядке то на обоих пинах (77, 78) будет присутствовать логическая "1", в противном случае, если драйвер к-линии не работает, т.е. на драйвере нет одного из питаний (+5, +12в) то на приёмнике проца не будет лог. " 1", если у проца отсутствует питание на 109 и 110 пинах то на передатчике проца не будет лог. "1"..................

Как то так..................

109 и 110 пинах  есть и земля и +5В. Микросхемы B58251 SOP16 и есть драйвер К-линии, но в этом ЭБУ К-линия не идет напрямую на драйвер, а идет через спец микросхему 30402. на 77 и 78 пинах проца (UART) есть +5В. Вот нашел картинку где написан аналог - AE372 но пока даташит не нашел

 

f456f1f710d8.jpg

1 час назад, dyrokol сказал:

Не понятно, обычно 77 и 78 пины проца (UART) идут на драйвер к-линии, если с драйвером к-линии всё в порядке то на обоих пинах (77, 78) будет присутствовать логическая "1", в противном случае, если драйвер к-линии не работает, т.е. на драйвере нет одного из питаний (+5, +12в) то на приёмнике проца не будет лог. " 1", если у проца отсутствует питание на 109 и 110 пинах то на передатчике проца не будет лог. "1"..................

Как то так..................

Володя извиняюсь - запросы на 78 пин проца (UART)-P3.111/RxD0 приходят, а вот ответов нету.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Проверяйте флешь, я уже выше писал про flashit, скачайте её и протестируйте проц, если проц живой то программа покажет его ID и состояние флешки жива или нет........

Прежде чем пользовать flashit надо проц перевести в BSL режим, для этого необходимо 104 пин проца, через сопротивление 6,8 кОм, посадить на массу, к стате в BSL режиме можно попытаться вычитать флешку flashit-ом или любым программатором который поддерживае данные процы в BSL- режиме.

Я думаю что ещё нужно проверить Reset проца, это 140-й или 141 пин проца какойто из них RESET IN, а какой то из них RESET OUT, в данном случае нужен IN. Дело в том что на многих мозгах с подобными процами ставят защиту проца, смысл этой защиты в том, что если она не получила какой то определённый ответ от проца то она его блокирует путём принудительной подачи лог. "0" на Reset, тем самым блокируеться запуск проца, тактовая частота присутствовать будет, а вот проц не запустися,

я надеюсь что понятно объяснил........

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
8 часов назад, dyrokol сказал:

Проверяйте флешь, я уже выше писал про flashit, скачайте её и протестируйте проц, если проц живой то программа покажет его ID и состояние флешки жива или нет........

Прежде чем пользовать flashit надо проц перевести в BSL режим, для этого необходимо 104 пин проца, через сопротивление 6,8 кОм, посадить на массу, к стате в BSL режиме можно попытаться вычитать флешку flashit-ом или любым программатором который поддерживае данные процы в BSL- режиме.

Я думаю что ещё нужно проверить Reset проца, это 140-й или 141 пин проца какойто из них RESET IN, а какой то из них RESET OUT, в данном случае нужен IN. Дело в том что на многих мозгах с подобными процами ставят защиту проца, смысл этой защиты в том, что если она не получила какой то определённый ответ от проца то она его блокирует путём принудительной подачи лог. "0" на Reset, тем самым блокируеться запуск проца, тактовая частота присутствовать будет, а вот проц не запустися,

я надеюсь что понятно объяснил........

Володя большое спасибо - все отлично понятно!  Что я уже сделал:

1. проверил прохождение сигнала "TX" от от процессора до К-линии  путем замыкания 77 пин проца (UART)-P3.111/TxD0 на землю - приходят

2. проверил осцилом шины адресные и данные на флэш - все хреново... (с Флэш 29F400BT работаю прогером) 

3. выпаял флэш - проверил все свзи с прогером - все ок. По осцилу на пинах флэш (без флэшки) проц нормально дает адресные запросы.

похоже я залил в флэш не дамп, а бог его знает чего - брал в инете было написано "...ORI_FULL.bin" - вот это я дал....))). Правда еще EPROM-ка стоит чистая, но она не должна влиять - я так меркую....???

По Reset понял - впаяю флэш, проверю.

Ищу дамп для железа EDC15C7 0281011690 или 0281011694 или любой EDC15C7 или EDC15C2, а флэш 29F400BT.

Если у кого есть дамп или ссылка рабочая киньте пожалуйста.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти
Авторизация  

  • Последние посетители   1 пользователь онлайн

×