Перейти к содержанию

Важное изменение в правилах форума!!! Обязательно к ознакомлению: http://carmasters.org/topic/20603-поправка-к-правилам-форума-№1-всем-ознакомиться-в-обязательном-порядке/

Criptic

Шьём Carprog Без Разборки С Помощью J-Link

Рекомендуемые сообщения

В 30.08.2016 в 14:08, MR_Serg сказал:

Как его стереть, если нет коннекта? Писать стирать можно только имея соединение с процом.

он же не коннектится с джей-линком пока не сотрешь
а после очистки снять питание, подать питание и тогда коннект

да и в целом проверьте правда +3,3 +5 если они на месте и после резета нет коннекта ищите проблему в подключении джей-линка

осцил у Вас есть? 55 ножку поднимали или у Вас отведена он нее удобная дорожка по заводу? если поднимали точно ничего не тронули поблизости?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

сегодня вечером всё проверю. С паяльником я на ты. Работаю под профессиональным стерео микроскопом. Поэтому косяки, по пайке исключены. Осцил есть. Питание на месте. Попробую подержать долго питание на 55 ноге. Проверю соединение. Тут может и ошибся. Ещё раз СПАСИБО за активную помощь. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

зачем держать питание еще, проц стерт походу и так
Вы когда пытаетесь коннектится джей-линком, софт видит питание на плате (+3,3)?

проверьте внимательно шлейф из джей-линка на плату карпрога - оно правильно обжат в разъеме

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

да правильно. Питание есть. В лог файле даже справа в низу видно. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Сергей сделайте все по порядку как описано выше . Повторю:

1. отпаять 55 ногу и подключить к 3,3V на контакт VDD, а не ERASE так ка на нем напряжение бывает просаживается ниже 3 вольт что мало стирания проца!! ( у меня так и было)

2. подключить внешнее питание 12V, а не USB!!! и подождать 10 сек. Отключить питание. ( Проц стерт) отпаять 55 ногу от 3.3V.

3. подключить J-Link по указанному выше посту .

4. скачать и распоковать на диск с: "J-link-carprog.rar"

5 открыть J-link ARM

6 открыть проект (File--> Open proeject ) с распакованной папки должно получиться как показано в скрине. после открыть " Open data file" и указать файл прошивки (он имеется в архиве или выбрать другой) 

7  Target---> Connect  и далее программируем!!!

J-link-carprog.rar

 

 

conf.JPG

pin-55-connect-to-Gnd-03-1024x768.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 07.09.2016 в 12:16, MR_Serg сказал:

да правильно. Питание есть. В лог файле даже справа в низу видно. 

Так как там дела обстоят у автора, есть какие-то сдвиги ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

парни, извините. Ещё раз всем огромное спасибо за помощь. То работа, то праздники, некогда было. Займусь плотно карпрогом 14 сентября, всё отпишу. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

У меня есть проблема с моим karprog.
Он был сожжен и процессор не определяется.
Я изменил процессор, записал ее, и начал признавать его как usb  но начать karprog не отображается серийный номер.
В чем проблема?

carprog problem.PNG

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
4 минуты назад, ghost2 сказал:

A lib файл лежит у вас в папке с прогой?
 

да

да

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

да

11 минут назад, joro_8002 сказал:

да

да, даже я взял друга из другого karprog с идентичными файлами и его sn: вне

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Всем привет. Вот выкроил день и время. Решил ещё раз всё проверить от и до!

1. Поднял проц,(Atmel AT91SAM7S256 AU) и убедился в том, что у меня 55 нога в воздухе, и никак ни к чему не притянута. Выходит на вторую сторону платы на площадку SMD где нет ничего. Поставил туда SMD резак (102) 1 кОм. для того, что бы притянуть 55 ногу к массе. Но на саму ногу, перед резаком, припаял провод, и вывел его через кнопку на (VTref) J-Link-а, что бы подавать туда кнопкой 3.3V и чистить проц.

2. Прозвонил все провода. Всё строго по вот этой схеме абсолютно соответствует. CarProg Shema Podkl..jpg

3. Чистил проц и 3.3V и 5V. Время 10 сек. и 60 сек. И 5 минут и 10 минут.

4. Замерял параллельно напругу во время очистки, Посадок и провалов не было. 

5. Пробовал коннектиться с внешним питанием. Причём не от USB а именно внешнее, через лабораторный ИПБ давал 12V и 14V причём стабилизаторы в карпроге, справлялись отлично, изменение внешнего питания никак не влияло на питание (внутреннее) проца. т.е. строго 3.26V и 5V. 

6. Ещё раз снова создал проект, сделал все настройки. J-link видит проц, но коннекта нету. Всё теже две ошибки:

1 -  ошибка, сразу после каждой очистки разная, вот пример одной из них: CarProg Error 1.jpg

2. Вот вторая ошибка, она постоянно одна и та же. Пока снова не очистишь проц. Вот как она выглядет:CarProg Error 2.jpg


Из этого, только один вывод, всё так же жду новые процики. Перепробовал кажется всё, чудес не бывает. Приедут новые процики, попробую снова, всё расскажу и всё подробно опишу. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
15 минут назад, MR_Serg сказал:

Всем привет. Вот выкроил жень и время. Решил ещё раз всё проверить от и до!

1. Поднял проц,(Atmel AT91SAM7S256 AU) и убедился в том, что у меня 55 нога в воздухе, и никак ни к чему не притянута. Выходит на вторую сторону платы на площадку SMD где нет ничего. Поставил туда SMD резак (102) 1 кОм. для того, что бы притянуть 55 ногу к массе. Но на саму ногу, перед резаком, припаял провод, и вывел его через кнопку на (VTref) J-Link-а, что бы подавать туда кнопкой 3.3V и чистить проц.

2. Прозвонил все провода. Всё строго по вот этой схеме абсолютно соответствует. CarProg Shema Podkl..jpg

3. Чистил проц и 3.3V и 5V. Время 10 сек. и 60 сек. И 5 минут и 10 минут.

4. Замерял параллельно напругу во время очистки, Посадок и провалов не было. 

5. Пробовал коннектиться с внешним питанием. Причём не от USB а именно внешнее, через лабораторный ИПБ давал 12V и 14V причём стабилизаторы в карпроге, справлялись отлично, изменение внешнего питания никак не влияло на питание (внутреннее) проца. т.е. строго 3.26V и 5V. 

6. Ещё раз снова создал проект, сделал все настройки. J-link видит проц, но коннекта нету. Всё теже две ошибки:

1 -  ошибка, сразу после каждой очистки разная, вот пример одной из них: CarProg Error 1.jpg

2. Вот вторая ошибка, она постоянно одна и та же. Пока снова не очистишь проц. Вот как она выглядет:CarProg Error 2.jpg


Из этого, только один вывод, всё так же жду новые процики. Перепробовал кажется всё, чудес не бывает. Приедут новые процики, попробую снова, всё расскажу и всё подробно опишу. 

Здравствуйте, у меня точно такая же проблема, и я также заказал новый процессор.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

ну вот и посмотрим, я в РБ, думаю тормознут на таможне на пару недель. :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Советую посмотреть внимательно мой скин!!! А еще лучше открыть выложеный мой проект!!! 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

сделал всё как описано, результат тот же:

1. CarProg Error 1.jpg

2. 
CarProg Error 2.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 29.02.2016 в 04:11, xlr сказал:

 

 

P2290188.JPG

Провода надо сдвинуть . Свободных только семь на разъеме . Там где 3,3 В посажен он занят . смотрите адаптер А10 , 22 нога использует +10В IRQ .

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

я по этой схеме не делал

СПАСИБО проверю

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Не путайте человека, свободных 8, подключены правильно. Не хватает минуса проводком. Всё пишется без проблем.

Не путайте человека, свободных 8, подключены правильно. Не хватает минуса проводком. Всё пишется без проблем.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

К сожалению ничего не путаю , а столкнулся . Я тоже тот пин задействовал , потом перецепил на другой . Перестала читаться моторола 1К20С , знаю что читалась прекрасно и проблем небыло , попробовал 4Е28 читается, а та ни в какую не хочет , провод отцепил и все прекрасно опять читается ...     Вот проверенный пример . В общем получается так - если задействован будет белый провод А10 будут проблемы в чтении с некоторыми мотями в таком подключении . Надо или провод перецеплять или дорожку к 22 ноге отрезать в А10
 

Малого того и не обошлось без танцев с бубном в карпроге. Начал читать 1К20С ... пару проб прочитать и получал слет прошивки карпрога. Перепрошиваю прогер, проверяю на правильность работы тестами , микрасхемами ... Все нормально . Как только к моте 1К20С так и пошли проблемы... Пока не разобрался, что импульсы 10 вольт прерывания идут на 3,3 вольта питания. Хорошо что импульсы короткие и только прошивка слетала. Ну с процессором  все нормально , обошлось

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 14.5.2015. в 22:01, ghost2 сказал:

 

Ну так прошивка там же, где и процессор, если следовать  логике. Но если вы знаете другое место, с собственно самой только прошивкой, так и помогите человеку.

Привет Я сделал все в соответствии с вашими указаниями прошивка пошел успешна, но почему CARPROG без подключения к компьютеру, и программа не отображается в левом углу Lib файл, который может быть проблемой.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Google переводил наверное. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 2016-09-29 в 10:57, mrsmg сказал:

К сожалению ничего не путаю , а столкнулся . Я тоже тот пин задействовал , потом перецепил на другой . Перестала читаться моторола 1К20С , знаю что читалась прекрасно и проблем небыло , попробовал 4Е28 читается, а та ни в какую не хочет , провод отцепил и все прекрасно опять читается ...     Вот проверенный пример . В общем получается так - если задействован будет белый провод А10 будут проблемы в чтении с некоторыми мотями в таком подключении . Надо или провод перецеплять или дорожку к 22 ноге отрезать в А10
 

Малого того и не обошлось без танцев с бубном в карпроге. Начал читать 1К20С ... пару проб прочитать и получал слет прошивки карпрога. Перепрошиваю прогер, проверяю на правильность работы тестами , микрасхемами ... Все нормально . Как только к моте 1К20С так и пошли проблемы... Пока не разобрался, что импульсы 10 вольт прерывания идут на 3,3 вольта питания. Хорошо что импульсы короткие и только прошивка слетала. Ну с процессором  все нормально , обошлось

тогда на какои пин вы переносите +3,3в провод?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Сдвинул все провода на один пин и в ответной частиCarprog пдключение.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×