Перейти к содержанию

Не забудьте отметить себя на карте для разблокировки некоторых функций форума: http://carmasters.org/membermap/

 

patrol79

Программы для адаптера ELM-327

Рекомендуемые сообщения

Чет нигде немогу найти TECU2 кругом платные разводы мож кто знает где качнуть?


Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

сборка под ELM для разных ОС



https://mega.co.nz/#!v1RRRKpB!BRrlYExWpsVDZ0ofgyymG4ngV_3GiK9l0lvvnHbbjS4

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

на форуме bk встретил..

аннотация от автора
 

ЕЛМ327 (v1.2 и выше) адаптация ДПКВ Дельфи ( P0315 / P1336).
Данные ошибки присущи блокам фирмы Дельфи. Т.е. датчик колена не обучен! (системная ошибка), часто встречется на Нексиях 1,5 Узбечках.... ну и там вариации.......

 

 

пробуем

Adapt_Dephi_11.rar

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Последняя версия FORScan 2.2.3b  от 2015-03-09


FORScanSetup2.2.3.beta.rar

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Програмулина которая сразу подключилась к мозгам моей праворукой HONDA stepwgn через китайский блютуз ELM 327 v1.5  это ScanMaster-ELM V2.1, хотя она и выдает при этом не всю инфу, которую хотелось бы, но это на ноуте под win XP.

На андроиде Torque  связался с эбу один раз и больше не хочет при этом hobdrive  связывается без проблемно но не стирает ошибки, а это собственно  задача номер один в случае чека в дороге. DashCommand стоит бесплатный тоже соединяется но очевидно из-за бесплатности тоже не может сбросить ошибку (DashCommand (OBD ELM Scanner) v4.5 (Full Version + All IAPs Unlocked) представленный выше еще не пробовал). Ошибка в обоих случаях не активная а сохраненная. 

Где то читал, что для торку надо прописать строку инициализации, которую можно взять из лога программы, которая подключается к этому эбу, но из какой программы не помню и где читал найти не могу может кто то владеет данной инфой.


Забыл добавить ссылку на полный  hobdrive, здесь он вроде еще не выкладывался

 

особенности установки
Необходимы root права android, в противном случае лицензия не подтвердится.
Итак, если root права имеются- идем дальше:
- Устанавливаем hobdrive_android_1198.apk, можно попробовать зайти, но попросит лицензию, не беда;
- Устанавливаем Lucky_Patcher_v5.1.3.apk .
- Запускаем Lucky Patcher, в левом нижним углу нажимаем на инструменты, видим надпись (установить модифицированный Google play) устанавливаем нужную версию маркета, если никаких ошибок не было, Вам сообщат, что маркет установлен, но нужно пропатчить core.jar - нажмите "Да".
- Если Ваш core.jar деодексированный, Вам предложат его одексировать (будет две перезагрузки, в противном случае одна).
- Всё готово, должно работать.

 

честно говоря полную версию, на моем аппарате не удалось установить т.к.  Lucky Patcher у меня не фурычит, но у других вроде работает

hobdrive_android_1198.zip

Lucky_Patcher_v5.1.3.zip

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Вот еще ссылка http://focccus.com/wiki/Main_Page Ford Focus III,Fiesta 7 и Kuga 2. Меня очень выручила

PCM не читает как  понял? а так спасибо, нужная вещь!)

Програмулина которая сразу подключилась к мозгам моей праворукой HONDA stepwgn через китайский блютуз ELM 327 v1.5  это ScanMaster-ELM V2.1, хотя она и выдает при этом не всю инфу, которую хотелось бы, но это на ноуте под win XP.

На андроиде Torque  связался с эбу один раз и больше не хочет при этом hobdrive  связывается без проблемно но не стирает ошибки, а это собственно  задача номер один в случае чека в дороге. DashCommand стоит бесплатный тоже соединяется но очевидно из-за бесплатности тоже не может сбросить ошибку (DashCommand (OBD ELM Scanner) v4.5 (Full Version + All IAPs Unlocked) представленный выше еще не пробовал). Ошибка в обоих случаях не активная а сохраненная. 

Где то читал, что для торку надо прописать строку инициализации, которую можно взять из лога программы, которая подключается к этому эбу, но из какой программы не помню и где читал найти не могу может кто то владеет данной инфой.

Забыл добавить ссылку на полный  hobdrive, здесь он вроде еще не выкладывался

 

особенности установки

Необходимы root права android, в противном случае лицензия не подтвердится.

Итак, если root права имеются- идем дальше:

- Устанавливаем hobdrive_android_1198.apk, можно попробовать зайти, но попросит лицензию, не беда;

- Устанавливаем Lucky_Patcher_v5.1.3.apk .

- Запускаем Lucky Patcher, в левом нижним углу нажимаем на инструменты, видим надпись (установить модифицированный Google play) устанавливаем нужную версию маркета, если никаких ошибок не было, Вам сообщат, что маркет установлен, но нужно пропатчить core.jar - нажмите "Да".

- Если Ваш core.jar деодексированный, Вам предложат его одексировать (будет две перезагрузки, в противном случае одна).

- Всё готово, должно работать.

 

честно говоря полную версию, на моем аппарате не удалось установить т.к.  Lucky Patcher у меня не фурычит, но у других вроде работает

у меня "лаки" тож не идет SGN-7000...мож самсунги не любит, хотя права есть...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

PCM не читает как  понял? а так спасибо, нужная вещь!)

Нет не читает но вроде как VBF (дилерский формат обновления), должна лить.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Здравствуйте. Скажите пожалуйста, какая из программ показыватает версию ПО адаптера ELM 327? Заказал у китайца два адаптера именно v1.5 , но мне кажется,что прислали версию 2.1,потому как не получается запустить прогу OpenDiag mobile и просканировать Ваз 2110 с ЭБУ Bosch. Китаец требует доказательств того, что он прислал версию 2.1 вместо обещанной 1.5


Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Здравствуйте. Скажите пожалуйста, какая из программ показыватает версию ПО адаптера ELM 327? Заказал у китайца два адаптера именно v1.5 , но мне кажется,что прислали версию 2.1,потому как не получается запустить прогу OpenDiag mobile и просканировать Ваз 2110 с ЭБУ Bosch. Китаец требует доказательств того, что он прислал версию 2.1 вместо обещанной 1.5

 

Добрый день. Scanmaster.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Кто что использует для диагностики блоков ваз кроме open diag?


Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для диагностики ваз под андроид хорош опендиаг

А для Windows есть следующая версия OpenDiag

OpenDiagFree1.4_setup.rar

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Подскажите elm v2.1 возможно переделать в 1.5?

 

 

нет elm v2.1   это блеф.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Просто сначала заказал с Китая а потом вычитал что он вроде не работает с моим авто вот жду когда придет

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Много негатива по китайским адаптерам ELM с версией 2.1. 
Работают только с OBD2 протоколом, любые KWP2000 протоколы - поддерживают криво и плохо, в большинстве случаев связь с ЭБУ не устанавливается.

Не понимает он команд для соединения с ЭБУ, а некоторые неправильно воспринимает:

SendCommand:ATAL 

HandleReply: ? - должно быть ОК 
-> EXTRAINIT 
SendCommand:ATIB10 
HandleReply: ELM327 v2.1 - должно быть ОК
-> EXTRAINIT 
SendCommand:ATSH8111F1 
HandleReply: OK 
-> EXTRAINIT 
SendCommand:ATST32 
HandleReply: OK 
-> EXTRAINIT 
SendCommand:ATSW00 
HandleReply: ? - должно быть ОК

 

Если для подключения к вашему ЭБУ необходимо прописывать строку инициализации елм (использовать шаблон строки инициализации елм), команды (ATIB10, ATAL, ATSW00 ... ) которые неправильно отрабатывает елм приходят ответы знак вопроса (на ATIB10 должен быть ответ ОК, а не версия elm адаптера), то такой адаптер нестандартные протоколы (KWP2000) не поддерживает (ЭБУ: Январь, Микас, Делфи...Авто: ВАЗы, Chery Tiggo, Nissan, Toyota JDM...)

то связь вы не установите! И дело здесь не в программе!

 

Но не все адаптеры версии 2.1 "кривые", хотя их большинство. Нормально работает адаптер версии 2.1 под названием Vgate ICar2 BTс протоколом KWP2000.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Я заказывал версию 2.1,а прислали 1.5,так что сначала протестируйте !


Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Диагностика автомобилей Рено через ELM327 v1,5 с помощью скрипта pyren

Возможности
- Сканирует и определяет типы ЭБУ на автомобилях Рено
- Считывает и показывает состояния, параметры и идентификации блоков
- Считывает и показывает текстовое описания ошибок ЭБУ, состояние ошибок и относящиеся к этим ошибкам параметры.
- Позволяет сбросить ошибки
- Позволяет выполнить команды не требующие параметров
- Код программы открытый. Любой желающий может изменять, исправлять и развивать её, использовать любые отрывки кода по всему усмотрению.
- Работает под OS Windows, можно легко запустить под Linux и MacOS
 
Расскажу про pyren. Начиная с версии 0.8 скрипт использует для свей работы базу данных от клипа и может показывать названия всех параметров на разных языках включая русский.
Последняя опубликованная на данный момент версия pyren v0.9.4 (beta)

Процесс инсталяции этой версии выглядит так:

0. Устанавливаем на свой компьютер Python
https://www.python.org/downloads/
(лучше поставить 2.7.x)

1. Скачиваем скрипт
http://takebin.com/f/Xx4gG26U0FdFE(У меня большинство браузеров не дало скачать, ругались на вирус, так, что качать или нет каждый решает сам, качал через K-Meleon)  или здесь  pyren_v094_beta.zip отсюда скачалось без проблем.

2. Добываем необходимые нам файлы из последней БД клипа. Для этого есть вот такая утилита
http://takebin.com/f/CEagR6sSlVl1R  (У меня большинство браузеров не дало скачать, ругались на вирус, так, что качать или нет каждый решает сам, качал через K-Meleon) или здесь extractgenApply.zip отсюда скачалось без проблем.

- Скачиваем из изветсных источников образ диска с клипом (на момент написания это v.151)
- Из корня образа диска стандартными методами добываем всего два файла data2.cab и data1.hdr. 
- Копируем их во временную директорию. 
- В эту же директорию разархивируем два файла из extractgenApply.zip
- Запускаем extract_gen.bat и он должен создать директорию GenAppli и скопировать туда все необходимое, включая все возможные языковые базы.
- Теперь data2.cab и data1.hdr можно удалить
- Осталось в genAppli забросить последнюю версию скрипта

3. Копируем папку со скриптом из пункта 1 в папку genApply которая получилась в пункте 2

4. Первый запуск 
- компьютер должен быть подключен к интернету. при первом запуске он должен скачать необходимые ему модули. при поледующих запусках интернет не нужен
- запустите приложение cmd.exe
- перейдите в директорию pyren с помощью команд CD
- запустите скрипт без параметров. После скачивания и установки нужных модулей он покажет сви ключи и доступные COM порты (к одному из которых должен быть подключен ELM327 v1.5)

5. Теперь подключитесь к машине и запустите скрипт с указанием COM порта

Например:

pyren.py -p COM6 
 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Добрый вечер.


Имею адаптер ELM 1.5 blut. и автос VW Touran 08 TDI.


Вопрос в следующем?


адаптер не хочет считывать ошибки с ЭБУ, т.е он их не видит, хотя висит точно одна постоянно.


Он в принцепе не пожет этого на VW, или надо еще шаманство?


спасибо


Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Может кому интересно? Для елмки взял переходник с 16пин на gm12пин,с целю смотреть матизы и нексии,но там как оказалось по питанию беда,везде разные ,так отрезал с 12gm и подключил на обд2,через прикуриватель,оставил только K-линию и L-линию.

20151205_135724.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 20.10.2015, 11:19:30, enteran сказал:

Диагностика автомобилей Рено через ELM327 v1,5 с помощью скрипта pyren

Проверил на нескольких Megane II.

С адаптером Орион bluetooth работает отлично. Продиагностировал аирбэг, комбинацию приборов.

Версию 0.97 проверил – работает. Запись логов включал (версия 0.94 без включенной записи логов вылетала с ошибкой), com17 и com18 поменял на com1 и com2 и появилась связь со всеми блоками. Полная расшифровка всех кодов на русском языке, что еще добавить. Отличный скрипт!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 28.05.2014 at 21:07, romsereb сказал:

Еще програмка для Форд с ELM 327.

 

ELM-FF2.zip

 

Рома посоветуй где в краснодаре через проверенных людей купить ELM . 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×