Jump to content

Важное изменение в правилах форума!!! Обязательно к ознакомлению: http://carmasters.org/topic/20603-поправка-к-правилам-форума-№1-всем-ознакомиться-в-обязательном-порядке/

Nonit

Востановление Xprog

Recommended Posts

Вот  фото моей проблемы.Глянте и направте если можно...Зарание благодарен..

Прав походу не хватает.

Share this post


Link to post
Share on other sites

всем доброго дня.Дождался я наконец свой новый прогер  upa 1.3 и теперь с помощью его хочу заняться сексом с xprogom 5.55.Проблему икса я описывал выше, Я ПРОШУ ПОМОЩИ разъяснить что мне нужно сделать поменять версию прошивки атмеги или  что то другое если да то подсказать что? Я только начинаю изучать это дело!! просьба понять и не посылать. Всем спасибо... 

Share this post


Link to post
Share on other sites

Приветствую. Сначала попробуйте считать прошивку с атмеги в х-проге, она не залочена. Считываете через то самое ISP (внутрисхемное программирование), точки тут уже приводили. Если удачно получилось считать, и прошивка "похожа на прошивку" (в начале прошивки меги должно быть что-то вроде 0C 94 9E 49 и длинная последовательность из "...18 95 18 95...", а не на кучку мусора вроде 00 или FF). Если это есть, значит прошивка считалась правильно, в противном случае проверяйте точки подключения программатора и тип выбранного микроконтроллера. В мегу нужно будет прошить 2 bin-файла, один файл это будет FLASH-секция меги, а второй файл будет EEPROM-секция. Не забудьте правильно выставить фьюзы! А то придется искать параллельный программатор! (и упа тут уже не поможет..). Собственно как-то так. Когда откроете архив с прошивкой - поймете о чем я говорю.

Share this post


Link to post
Share on other sites

доброго дня.Вот приехала мая уппа и оппа.Прошивку как и писали я считал.полазил по форуму нашел рем комплект и даже его туда залил и не чего не поменялось даже купил новую мегу заил туда и старую и новую и не чего девайс ис селент?делал все как описано выше к сожалению не чего не помогло что делать не знаю. может дело не в меге? 

да фъюзы и лок биты ставлю как показано.даже один раз запарился и без выставления фъюзов стерлась и прошилась так же,совсем  каша в голове!!

куда копать? подтолкните на какие мысли что-ли

 

Share this post


Link to post
Share on other sites

Можно немного подробней,(Не забудьте правильно выставить фьюзы! А то придется искать параллельный программатор! (и упа тут уже не поможет..)вопрос почему???

Share this post


Link to post
Share on other sites

Подскажите.я правельно понял что во всем виновата мега или может еще что то здесь не так.Кстати китаец на связь больше не выходит.

Share this post


Link to post
Share on other sites
В 30.07.2016 в 09:31, sery5555 сказал:

Можно немного подробней,(Не забудьте правильно выставить фьюзы! А то придется искать параллельный программатор! (и упа тут уже не поможет..)вопрос почему???

Приветствую, Сергей! Сейчас попробую объяснить в двух словах: параллельный программатор придется искать собственно потому, что если ты заденешь фьюз, отвечающий за одну из линий внутрисхемного программирования, то воспользоваться им уже не получится!..На память критичные фьюзы это SPIEN - запрет внутрисхемного (последовательного) программирования, RSTDISBL - отключение ножки сброса МК, для использования по своему усмотрению (в этом случае внутрисхемно запрограммировать МК уже не получится), ну и внимательно следить за правильной установкой частоты тактового генератора (по памяти это 4 бита фьюзов CKSEL0..3). И еще почитайте даташит на этот МК..

P.S. Самый дешевый способ без покупки параллельного программатора оживить сдохший или залоченный

МК это использовать FuseBit Doctor - посмотрите схему и прошивку в интернете..главное чтобы не получилось как в притче с курочкой и яичком...Начнете собирать доктора, и тоже завалите его мегу)) :dada: Желаю удачи с ремонтом!!!

Share this post


Link to post
Share on other sites

  я не  могу понять почему понадобится еще один программатор.Уппа что разве не программатор???Извиняюсь за свою темноту.Но программистом  ведь тоже не раждаются!!!!Прошу понять и простить....

 

Share this post


Link to post
Share on other sites

Взял свою старую мегу котороя стояла в хпроге припоял ее на переходник и подключил как в даташите читает но писать не получается?в чем прикол,подключил вроде правильно.

Share this post


Link to post
Share on other sites

всем привет,может кто направит на путь ,Xprog перестал читать наверное все кроме eeprom и то 24 серию тоже не читает,давал прочесть камни моторолла 05,11,08 также TMS370 все на родных постелях и никак,при чтении 05 не каких ошибок не выдает тупо без памяти пытается ее прочесть,ах да 24 серию не читал с самого рождения,прибор не обновлял

Share this post


Link to post
Share on other sites

Если возможно скины в студию!!! ( и ни кто за это не пошлет и ругать не будет, а  быть телепатом и гадать на кофейной гуще так долго придется ремонтировать!!!!   

Share this post


Link to post
Share on other sites

Дима для начала попробуй вскрыть и проверить пайки. Далее что на втором скрине TMS выбран С010А ,а должно быть С002А если от иммо опеля . Если и при этом проблема не решится остается прошивать и восстанавливать упой (он я вижу имеется). 

Share this post


Link to post
Share on other sites

все пайки проверил в первую очередь,решено купить атмегу с версией 5,55 а результате если нужно отпишусь 

Share this post


Link to post
Share on other sites
1 час назад, димас т сказал:

все пайки проверил в первую очередь,решено купить атмегу с версией 5,55 а результате если нужно отпишусь 

А зачем покупать если есть программатор и прошивка!!! Взять и самому прошить . 

Share this post


Link to post
Share on other sites

Тоже столкнулся с прошивкой атмеги от х-прог, шил упой. Стираю, заливаю флешь, епром, выставляю фьизы и локбиты, упа пишет: саксес при каждой операции, но верифи не проходит, при чтении одни FF. До меня этот проц побывал у другого человека, получается он его залочил или я что то не то делаю?

как понять, залочен проц или нет?

Сейчас заказал еще проц,сдую в крайнем случае

Share this post


Link to post
Share on other sites

Так и должно быть ! Если лок биты выставляешь то потом программатором читаются записанные данные как FF. Процессор же закрывается и включается защита. А при veryfy идет сравнение с буфером обмена компа . Вот и не будет проходить. Поэтому они ставятся в последнюю очередь. Когда они не установлены проверка должна пройти. 

Share this post


Link to post
Share on other sites
2 часа назад, mrsmg сказал:

Так и должно быть ! Если лок биты выставляешь то потом программатором читаются записанные данные как FF. Процессор же закрывается и включается защита. А при veryfy идет сравнение с буфером обмена компа . Вот и не будет проходить. Поэтому они ставятся в последнюю очередь. Когда они не установлены проверка должна пройти. 

Спасибо, x prog  ожил

Share this post


Link to post
Share on other sites
Цитата

 

Народ. Загубил кетайский xprog V5.70, всё работало, но нашел софт V5.8, когда подключился он мне сразу предложил обновить прошивку, что я сделал. Теперь бокс в нерабочем состоянии, прошиваться больше не хочет, выдаёт ошибку соединения. Вот тут на сайте http://blog.obd2diy.fr/2017/04/21/how-to-update-xprog-m-v5-0-without-dongle-to-xprog-m-v5-74/ нашел прошивку под 5.7 (атмега64а уже стоит). Я так понимаю в папке firmware нужны два бинарных файла 64кб флэш и 2кб епром. Заливаю их при помощи UPA usb, но результата нет, выдает ошибку device silent. Что не так делаю? или поделитесь кто-нибудь рабочей прошивкой под 5.7

111.jpg

222.jpg

IMG_5504.JPG

Share this post


Link to post
Share on other sites
15 часов назад, СЭР сказал:

Народ. Загубил кетайский xprog V5.70, всё работало, но нашел софт V5.8, когда подключился он мне сразу предложил обновить прошивку, что я сделал. Теперь бокс в нерабочем состоянии, прошиваться больше не хочет, выдаёт ошибку соединения. Вот тут на сайте http://blog.obd2diy.fr/2017/04/21/how-to-update-xprog-m-v5-0-without-dongle-to-xprog-m-v5-74/ нашел прошивку под 5.7 (атмега64а уже стоит). Я так понимаю в папке firmware нужны два бинарных файла 64кб флэш и 2кб епром. Заливаю их при помощи UPA usb, но результата нет, выдает ошибку device silent. Что не так делаю? или поделитесь кто-нибудь рабочей прошивкой под 5.7

111.jpg

222.jpg

IMG_5504.JPG

надо записать правильно атмегу, 1 флэш 2 епрром 3 фусе бит 

Share this post


Link to post
Share on other sites

А у меня проблемка следующего характера - при записи флеши - повреждает дамп . Не могу понять ,по какой причине 

 

x5n62b48_xprog_flash_CS3.rar

9 минут назад, archi09 сказал:

А у меня проблемка следующего характера - при записи флеши - повреждает дамп . Не могу понять ,по какой причине 

 

x5n62b48_xprog_flash_CS3.rar

Это здоровый файл 

x5n62b48_xprog_flashCS3_vol1.rar Это уже поврежденный файл 

Share this post


Link to post
Share on other sites
5 часов назад, димас т сказал:

как читал евс ?

В комплекте был так скажем переходник,(плата) ее подсоленил к программатору вторую часть в евс,согласно распиновка,и попутно припаял щуп на 22 ногу,ну как бы и все 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×